Error # 2072 Specific symptom number: 4 Mac OS X There was an unanticipated problem with the license for this product

Technote (troubleshooting)

 

Problem(Abstract)

Launching Statistics on a Apple MacBook Air, MacBook Pro, iMac, or Mac mini using Thunderbolt Technology.

‘Error # 2072

There was an unanticipated problem with the license for this product.

Execution of this command stops. >Specific symptom number: 4’


Symptom

Launching Statistics on a Apple MacBook Air, MacBook Pro, iMac, or Mac mini using Thunderbolt Technology.
----------------------------------------
Pop-Up Entitled: IBM SPSS Statistics xx (i.e. 20, 21, or 22 depending on the installed version of Statistics)
.........................
'There was an unanticipated problem with the license for this product.
Specific symptom number: 4'
Followed by an [OK] button.
----------------------------------------
Error Message in Statistics Output Window (.spv):
.........................
>Error # 2072
>There was an unanticipated problem with the license for this product.
>Execution of this command stops. >Specific symptom number: 4

 

Cause

Booting the Mac OS X ThunderBolt Monitor versus the Laptop Monitor uses a different lock code of 10-, therefore the device used to activate the license is the one that the license is tethered to.

Here is an article on how to determine if you’re using thunderbolt technology:

http://www.transcend-info.com/Support/FAQ-921


Resolving the problem

To correct the error (2072/4) you will need to change the Statistics applications tethering locking code from using a NIC Card tether (10) to using a Hard Drive tether (4), which is less likely to change.

You will need to know the path of where IBM SPSS Statistics is installed.
Depending of the version of Statistics you have installed the paths will vary.
NOTE: Steps one through six below may vary if you did not use the software's default path, so modify accordingly.

Here are some of versions of Statistics and their default paths.

[Defaults paths]
Statistics 20.0: /Applications/IBM/SPSS/Statistics/20/SPSSStatistics.app/Contents/bin
Statistics 21.0: /Applications/IBM/SPSS/Statistics/21/SPSSStatistics.app/Contents/bin
Statistics 22.0: /Applications/IBM/SPSS/Statistics/22/SPSSStatistics.app/Contents/bin

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1) Open up FINDER
2) Open up the APPLICATIONS folder
3) Open up the IBM folder
4) Open up the SPSS folder
5) Open up the Statistics folder
6) Open up the version of Statistics xx.x (20, 21, or 22 depending on the installed version of Statistics)
7) Locate the "SPSSStatistics.app" (application bundle) right click and choose "Show Package Contents".
8) Open up the "Contents" folder
9) Open up the "bin" folder
10) Locate and Control Click echoid.dat and choose Open With, and then choose
TextEdit.app
11) Change the 0x010 to 0x004
12) Save the echoid.dat file
13) Delete the current lservrc file in this directory (if one exists, if not continue)
14) Run the License Authorization Wizard
15) Re-launch Statistics. The software should now launch without error.
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